Add CurtainGrid on the specified face for the CurtainSystem.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Syntax
C# |
---|
public void AddCurtainGrid( Reference face ) |
Visual Basic |
---|
Public Sub AddCurtainGrid ( _ face As Reference _ ) |
Visual C++ |
---|
public: void AddCurtainGrid( Reference^ face ) |
Parameters
- face
- Type: Autodesk.Revit.DB..::..Reference
The face new CurtainGrid will be created on.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when the input argument face is nullNothingnullptra null reference (Nothing in Visual Basic). |
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when creating CurtainGrid on the specified face fails or regenerate fails. |