Returns the number of the bend on the other Rebar Element to which this RebarConstraint is attached.
The RebarConstraint must be of RebarConstraintType 'ToOtherRebar,' and the TargetRebarConstraintType
must be 'BarBend.'
Rebar must be Shape Driven Rebar element.
Namespace: Autodesk.Revit.DB.StructureAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since:
2014
Syntax
C# |
---|
public int GetTargetRebarBendNumber() |
Visual Basic |
---|
Public Function GetTargetRebarBendNumber As Integer |
Visual C++ |
---|
public:
int GetTargetRebarBendNumber() |
Exceptions
Exception | Condition |
---|
Autodesk.Revit.Exceptions..::..InvalidOperationException |
RebarConstraint is no longer valid.
-or-
The RebarConstraint is not of RebarConstraintType 'ToOtherRebar.'
-or-
The RebarTargetConstraintType is not 'BarBend'
-or-
Constrained rebar is a free form rebar element.
|
See Also