Retrieves a list of the parameters associated with each rule in the filter.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2019
Syntax
C# |
---|
public ISet<ElementId> GetElementFilterParameters() |
Visual Basic |
---|
Public Function GetElementFilterParameters As ISet(Of ElementId) |
Visual C++ |
---|
public: ISet<ElementId^>^ GetElementFilterParameters() |
Return Value
A set of parameter identifiers.
Remarks
This function returns only parameters used by this ParameterFilterElement that are common
to all categories specified in this ParameterFilterElement.
The ElementFilter may also contain parameters specific to one of the categories
and not necessarily common to all categories specified in this ParameterFilterElement.
To get those parameters, use ParameterFilterElement.GetElementFilterParametersForCategory().