Compares this ModelPath with another
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2012
Syntax
C# |
---|
public int Compare( ModelPath otherPath ) |
Visual Basic |
---|
Public Function Compare ( _ otherPath As ModelPath _ ) As Integer |
Visual C++ |
---|
public: int Compare( ModelPath^ otherPath ) |
Parameters
- otherPath
- Type: Autodesk.Revit.DB..::..ModelPath
The path to compare against.
Return Value
A signed integer indicating the lexical relationship between two ModelPaths. Value is less than zero if this path is less than the given path; zero if the two are the same; and more than zero otherwise
Remarks
The comparison is case-insensitive.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |