A constraint which can be applied to a RebarShapeSegment and drives the angle
of the segment relative to a fixed direction in UV-space.
Namespace: Autodesk.Revit.DB.StructureAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2012
Syntax
C# |
---|
public class RebarShapeConstraintAngleFromFixedDir : RebarShapeConstraint |
Visual Basic |
---|
Public Class RebarShapeConstraintAngleFromFixedDir _ Inherits RebarShapeConstraint |
Visual C++ |
---|
public ref class RebarShapeConstraintAngleFromFixedDir : public RebarShapeConstraint |
Inheritance Hierarchy
System..::..Object
Autodesk.Revit.DB.Structure..::..RebarShapeConstraint
Autodesk.Revit.DB.Structure..::..RebarShapeConstraintAngleFromFixedDir
Autodesk.Revit.DB.Structure..::..RebarShapeConstraint
Autodesk.Revit.DB.Structure..::..RebarShapeConstraintAngleFromFixedDir