Gets the user-visible name for a ParameterType.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Syntax
C# |
---|
public static string GetLabelFor( ParameterType paramType ) |
Visual Basic |
---|
Public Shared Function GetLabelFor ( _ paramType As ParameterType _ ) As String |
Visual C++ |
---|
public: static String^ GetLabelFor( ParameterType paramType ) |
Parameters
- paramType
- Type: Autodesk.Revit.DB..::..ParameterType
The ParameterType to get the user-visible name.
Remarks
The name is obtained in the current Revit language.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when failed to get user-visible name for the input ParameterType. |