Remove an existing distribution system type from the project.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)

Syntax

C#
public void RemoveDistributionSysType(
	DistributionSysType distributionSysType
)
Visual Basic
Public Sub RemoveDistributionSysType ( _
	distributionSysType As DistributionSysType _
)
Visual C++
public:
void RemoveDistributionSysType(
	DistributionSysType^ distributionSysType
)

Exceptions

ExceptionCondition
Autodesk.Revit.Exceptions..::..InvalidOperationException Distribution system type can be removed only if it is not currently assigned to any devices, otherwise an exception will be thrown.

See Also