Gets the family name of this element type.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2015
Syntax
C# |
---|
public string FamilyName { get; } |
Visual Basic |
---|
Public ReadOnly Property FamilyName As String Get |
Visual C++ |
---|
public: property String^ FamilyName { String^ get (); } |
Remarks
This value is a localized string describing the family in which this ElementType
belongs. For family symbols, this will be the name of the associated Family.
For system family types, this will be the name used to group related types,
such as "Oval Duct" or "Curtain Wall".