Creates a new LoadCase.
Namespace: Autodesk.Revit.DB.StructureAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2017
Syntax
C# |
---|
public static LoadCase Create( Document document, string name, ElementId natureId, ElementId subcategoryId ) |
Visual Basic |
---|
Public Shared Function Create ( _ document As Document, _ name As String, _ natureId As ElementId, _ subcategoryId As ElementId _ ) As LoadCase |
Visual C++ |
---|
public: static LoadCase^ Create( Document^ document, String^ name, ElementId^ natureId, ElementId^ subcategoryId ) |
Parameters
- document
- Type: Autodesk.Revit.DB..::..Document
The Document to which new load case element will be added.
- name
- Type: System..::..String
The name of the load case.
- natureId
- Type: Autodesk.Revit.DB..::..ElementId
The load nature ID.
- subcategoryId
- Type: Autodesk.Revit.DB..::..ElementId
The load case subcategory ID. Could be one of predefined or user defined load case category. Built-in structural Load Cases (OST_LoadCases) subcategories are: OST_LoadCasesDeadOST_LoadCasesLiveOST_LoadCasesWindOST_LoadCasesSnowOST_LoadCasesRoofLiveOST_LoadCasesAccidentalOST_LoadCasesTemperatureOST_LoadCasesSeismic
Return Value
The newly created load case element if successful, nullNothingnullptra null reference (Nothing in Visual Basic) otherwise.
Remarks
This method is designed to create LoadCase that is associated with user defined category.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentException | The given name is not unique. |
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |