Gets the user-visible name for a PipeFlowState.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Syntax
C# |
---|
public static string GetLabelFor( PipeFlowState pipeFlowState, Document doc ) |
Visual Basic |
---|
Public Shared Function GetLabelFor ( _ pipeFlowState As PipeFlowState, _ doc As Document _ ) As String |
Visual C++ |
---|
public: static String^ GetLabelFor( PipeFlowState pipeFlowState, Document^ doc ) |
Parameters
- pipeFlowState
- Type: Autodesk.Revit.DB.Plumbing..::..PipeFlowState
The PipeFlowState to get the user-visible name.
- doc
- Type: Autodesk.Revit.DB..::..Document
The document from which to get the PipeFlowState.
Remarks
The name is obtained in the current Revit language.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when information for the input PipeFlowState cannot be found. |