Gets the file name that will be produced when exporting a view to an image.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2015
Syntax
C# |
---|
public static string GetFileName( Document aDoc, ElementId dbViewId ) |
Visual Basic |
---|
Public Shared Function GetFileName ( _ aDoc As Document, _ dbViewId As ElementId _ ) As String |
Visual C++ |
---|
public: static String^ GetFileName( Document^ aDoc, ElementId^ dbViewId ) |
Parameters
- aDoc
- Type: Autodesk.Revit.DB..::..Document
The document that owns the view.
- dbViewId
- Type: Autodesk.Revit.DB..::..ElementId
View which is to be exported as image.
Return Value
The generated exported image file name.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |