The position of the dimension text's drag point.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2015 Subscription Update
Syntax
Remarks
This property is not applicable to all dimensions. For example, it is not available for spot dimensions, dimensions using equality formula, and when dimension style is ordinate.
If the position is not applicable, this property returns NULL and will not allow setting a value.
Examples

// Get the current text XYZ position XYZ currentTextPosition = currentSegment.TextPosition; // Calculate a new XYZ position by transforming the current text position XYZ newTextPosition = Transform.CreateTranslation(new XYZ(0, 1, 0)).OfPoint(currentTextPosition); // Set the new text position for the segment's text currentSegment.TextPosition = newTextPosition;
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ApplicationException | Thrown when the dimension text is unavailable. |
Autodesk.Revit.Exceptions..::..InvalidOperationException |
Thrown when:
|