Identifies whether a given element can host reinforcement.
Namespace: Autodesk.Revit.DB.StructureAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2015
Syntax
C# |
---|
public static bool IsValidHost( Element element ) |
Visual Basic |
---|
Public Shared Function IsValidHost ( _ element As Element _ ) As Boolean |
Visual C++ |
---|
public: static bool IsValidHost( Element^ element ) |
Parameters
- element
- Type: Autodesk.Revit.DB..::..Element
The element to check.
Return Value
True if the input Element can host reinforcement elements, false otherwise.
Remarks
Many different elements are permitted to host reinforcement,
for example, beams, walls, columns, or parts.
Often there are specific restrictions about whether an element
can host rebar beyond its type or category.
For example, the material type of the element may determine this.
Or for parts, the part must have been created from layers
that have their function set to Structure.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |