Gets the default view name that will be used when creating a schedule.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2013
Syntax
C# |
---|
public static string GetDefaultNameForSchedule( Document document, ElementId categoryId, ElementId areaSchemeId ) |
Visual Basic |
---|
Public Shared Function GetDefaultNameForSchedule ( _ document As Document, _ categoryId As ElementId, _ areaSchemeId As ElementId _ ) As String |
Visual C++ |
---|
public: static String^ GetDefaultNameForSchedule( Document^ document, ElementId^ categoryId, ElementId^ areaSchemeId ) |
Parameters
- document
- Type: Autodesk.Revit.DB..::..Document
The document to which the new schedule will be added.
- categoryId
- Type: Autodesk.Revit.DB..::..ElementId
The ID of the category whose elements will be included in the schedule, or InvalidElementId for a multi-category schedule.
- areaSchemeId
- Type: Autodesk.Revit.DB..::..ElementId
The ID of an area scheme in an area schedule, InvalidElementId otherwise.
Return Value
The default view name.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentException | document is not a project document. -or- categoryId is not a valid category for a regular schedule. -or- In a non-area schedule, areaSchemeId is not InvalidElementId. -or- In an area schedule, areaSchemeId is not the ID of an area scheme. |
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |