Gets registered external resource servers which support the external resource type.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2015
Syntax
C# |
---|
public static IList<IExternalResourceServer> GetServersByType( ExternalResourceType type ) |
Visual Basic |
---|
Public Shared Function GetServersByType ( _ type As ExternalResourceType _ ) As IList(Of IExternalResourceServer) |
Visual C++ |
---|
public: static IList<IExternalResourceServer^>^ GetServersByType( ExternalResourceType^ type ) |
Parameters
- type
- Type: Autodesk.Revit.DB..::..ExternalResourceType
The external resource type for the servers to match
Return Value
A list of matched external resource servers
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |