Checks whether or not the mechanical discipline is enabled, and enable or disable it.
Namespace: Autodesk.Revit.ApplicationServicesAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2013
Syntax
C# |
---|
public bool IsMechanicalEnabled { get; set; } |
Visual Basic |
---|
Public Property IsMechanicalEnabled As Boolean Get Set |
Visual C++ |
---|
public: property bool IsMechanicalEnabled { bool get (); void set (bool value); } |
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..InvalidOperationException | When setting this property: The current product type is not ProductType.Revit and discipline controls are not enabled. |