Gets information about specific KeyBasedTreeEntry objects that could not be included in the KeyBasedTreeEntries
object due to errors of a particular type.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2015
Syntax
C# |
---|
public IList<KeyBasedTreeEntryError> GetKeyBasedTreeEntryErrors( KeyBasedTreeEntryErrorType type ) |
Visual Basic |
---|
Public Function GetKeyBasedTreeEntryErrors ( _ type As KeyBasedTreeEntryErrorType _ ) As IList(Of KeyBasedTreeEntryError) |
Visual C++ |
---|
public: IList<KeyBasedTreeEntryError^>^ GetKeyBasedTreeEntryErrors( KeyBasedTreeEntryErrorType type ) |
Parameters
- type
- Type: Autodesk.Revit.DB..::..KeyBasedTreeEntryErrorType
The type of KeyBasedTreeEntryError to be returned.
Return Value
An array of copies of the KeyBasedTreeEntryErrors contained in this object matching the type specified.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration |