Create a new pipe ConnectorElement with a face and an edge.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2014
Syntax
C# |
---|
public static ConnectorElement CreatePipeConnector( Document document, PipeSystemType pipeSystemType, Reference planarFace, Edge edge ) |
Visual Basic |
---|
Public Shared Function CreatePipeConnector ( _ document As Document, _ pipeSystemType As PipeSystemType, _ planarFace As Reference, _ edge As Edge _ ) As ConnectorElement |
Visual C++ |
---|
public: static ConnectorElement^ CreatePipeConnector( Document^ document, PipeSystemType pipeSystemType, Reference^ planarFace, Edge^ edge ) |
Parameters
- document
- Type: Autodesk.Revit.DB..::..Document
The document to add the connector to.
- pipeSystemType
- Type: Autodesk.Revit.DB.Plumbing..::..PipeSystemType
The PipeSystemType of the connector.
- planarFace
- Type: Autodesk.Revit.DB..::..Reference
The planar face to place the connector on.
- edge
- Type: Autodesk.Revit.DB..::..Edge
One of the edges in the edge loop that defines the connector location on the planar face.
Return Value
The pipe ConnectorElement.
Remarks
Regenerates the document.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentException | The reference is not a planar face. -or- document is not a family document. -or- Thrown when the edge does not belong to the face. |
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration |
Autodesk.Revit.Exceptions..::..InvalidOperationException | Connector creation is not allowed in this family. |