Return the parameter's formula, if one is associated with it.
Namespace: Autodesk.Revit.DB.StructureAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2009
Syntax
C# |
---|
public string GetParameterFormula( ElementId paramId ) |
Visual Basic |
---|
Public Function GetParameterFormula ( _ paramId As ElementId _ ) As String |
Visual C++ |
---|
public: String^ GetParameterFormula( ElementId^ paramId ) |
Parameters
- paramId
- Type: Autodesk.Revit.DB..::..ElementId
Id of a parameter in the definition.
Return Value
The formula, or an empty string if there is no formula for the parameter.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentException | This RebarShapeDefinition does not have a value for the parameter paramId. |
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |