Specifies which wire direction of the fabric sheet is bent.
Namespace: Autodesk.Revit.DB.StructureAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2016
Syntax
C# |
---|
public BentFabricBendDirection BentFabricBendDirection { get; set; } |
Visual Basic |
---|
Public Property BentFabricBendDirection As BentFabricBendDirection Get Set |
Visual C++ |
---|
public: property BentFabricBendDirection BentFabricBendDirection { BentFabricBendDirection get (); void set (BentFabricBendDirection value); } |
Remarks
This parameter applies only to bent fabric sheets.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentException | When setting this property: the data-setting method is not applicable to fabric sheets that are flat |
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: A value passed for an enumeration argument is not a member of that enumeration |
Autodesk.Revit.Exceptions..::..DisabledDisciplineException | When setting this property: None of the following disciplines is enabled: Structural. |
Autodesk.Revit.Exceptions..::..InvalidObjectException | When setting this property: The data-setting method is not applicable to fabric sheets that are flat. |