Returns the necessary information to define a NURBS surface for a given Revit HermiteFace or RuledFace.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2017
Syntax
C# |
---|
[ObsoleteAttribute("This method is deprecated in Revit 2021 and will be removed in the next version of Revit. We suggest you instead use getNurbsSurfaceDataForSurface.")] public static NurbsSurfaceData GetNurbsSurfaceDataForFace( Face face ) |
Visual Basic |
---|
<ObsoleteAttribute("This method is deprecated in Revit 2021 and will be removed in the next version of Revit. We suggest you instead use getNurbsSurfaceDataForSurface.")> _ Public Shared Function GetNurbsSurfaceDataForFace ( _ face As Face _ ) As NurbsSurfaceData |
Visual C++ |
---|
[ObsoleteAttribute(L"This method is deprecated in Revit 2021 and will be removed in the next version of Revit. We suggest you instead use getNurbsSurfaceDataForSurface.")] public: static NurbsSurfaceData^ GetNurbsSurfaceDataForFace( Face^ face ) |
Parameters
- face
- Type: Autodesk.Revit.DB..::..Face
The HermiteFace or RuledFace to be converted.
Return Value
A class containing the necessary data to define a NURBS surface.
Remarks
This function is intended for export purposes
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentException | This face type is not supported for this function. -or- GetNurbsSurfaceDataForFace only supports Hermite surfaces. |
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |
Autodesk.Revit.Exceptions..::..InvalidOperationException | Couldn't get NURBS data from face. |