Set u and v coordinates that specify a grid on the surface.
The display of the grid is controlled by AnalysisDisplayColoredSurfaceSettings::getShowGridLines().
If AnalysisDisplayColoredSurfaceSettings::getShowGridLines() returns true and both sets are empty
then a grid will be displayed using a default spacing; if only one of the sets is non-empty, then
only the corresponding set of grid lines will be displayed, i.e. the grid will consist solely of
parallel lines at the specified coordinates.
Namespace: Autodesk.Revit.DB.AnalysisAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since:
2011
Syntax
C# |
---|
public void SetGridCoordinates(
ICollection<double> uCoordinates,
ICollection<double> vCoordinates
) |
Visual Basic |
---|
Public Sub SetGridCoordinates ( _
uCoordinates As ICollection(Of Double), _
vCoordinates As ICollection(Of Double) _
) |
Visual C++ |
---|
public:
void SetGridCoordinates(
ICollection<double>^ uCoordinates,
ICollection<double>^ vCoordinates
) |
Parameters
- uCoordinates
- Type: System.Collections.Generic..::..ICollection<(Of <(<'Double>)>)>
Set of u coordinates at which to draw grid lines
- vCoordinates
- Type: System.Collections.Generic..::..ICollection<(Of <(<'Double>)>)>
Set of v coordinates at which to draw grid lines
Exceptions
See Also