Removes one or more subelements from a StructuralConnectionHandlerType. The subelements will be erased.
Namespace: Autodesk.Revit.DB.StructureAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2017
Syntax
C# |
---|
public static void RemoveMainSubelementsFromCustomConnection( StructuralConnectionHandler structuralConnectionHandler, IList<Subelement> subelements ) |
Visual Basic |
---|
Public Shared Sub RemoveMainSubelementsFromCustomConnection ( _ structuralConnectionHandler As StructuralConnectionHandler, _ subelements As IList(Of Subelement) _ ) |
Visual C++ |
---|
public: static void RemoveMainSubelementsFromCustomConnection( StructuralConnectionHandler^ structuralConnectionHandler, IList<Subelement^>^ subelements ) |
Parameters
- structuralConnectionHandler
- Type: Autodesk.Revit.DB.Structure..::..StructuralConnectionHandler
The existing StructuralConnectionHandler having custom StructuralConnectionHandlerType which is about to be modified.
- subelements
- Type: System.Collections.Generic..::..IList<(Of <(<'Subelement>)>)>
The main Subelements of input StructuralConnectionHandler which are to be used to modify custom StructuralConnectionHandlerType.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentException | Input StructuralConnectionHandler must have custom type. -or- All the input Subelements must belong to input StructuralConnectionHandler. After modification of StructuralConnectionHandlerType there must remain at least one subelement of structural connections category in StructuralConnectionHandler. |
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |