Add a definition to be reused by instances. A definition is a collection of geometry objects.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since:
2015
Syntax
C# |
---|
public void AddDefinition(
string id,
IList<GeometryObject> GNodes
) |
Visual Basic |
---|
Public Sub AddDefinition ( _
id As String, _
GNodes As IList(Of GeometryObject) _
) |
Visual C++ |
---|
public:
void AddDefinition(
String^ id,
IList<GeometryObject^>^ GNodes
) |
Parameters
- id
- Type: System..::..String
ID of the definition to be added. Must be unique.
- GNodes
- Type: System.Collections.Generic..::..IList<(Of <(<'GeometryObject>)>)>
Definition as a list of Geometry objects
Exceptions
See Also