Splits horizontally one region in split crop.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2016
Syntax
C# |
---|
public void SplitRegionHorizontally( int regionIndex, double leftPart, double rightPart ) |
Visual Basic |
---|
Public Sub SplitRegionHorizontally ( _ regionIndex As Integer, _ leftPart As Double, _ rightPart As Double _ ) |
Visual C++ |
---|
public: void SplitRegionHorizontally( int regionIndex, double leftPart, double rightPart ) |
Parameters
- regionIndex
- Type: System..::..Int32
Index of region to be split horizontally (numbering starts with 0).
- leftPart
- Type: System..::..Double
Relative portion of the original region to become the new left region (0 to 1).
- rightPart
- Type: System..::..Double
Relative portion of the original region to become the new right region (0 to 1).
Remarks
This function splits the crop into two regions: one occupying the left quarter of the crop, and the other the right quarter of the crop.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentException | The provided view region proportions are not valid. -or- The provided region index is invalid. |
Autodesk.Revit.Exceptions..::..InvalidOperationException | The crop of the associated view is not permitted to have multiple regions. -or- The view has non-rectangular crop shape set. -or- The view crop is already split vertically. |