Sets the DirectShapeType for the DirectShape element.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2015
Syntax
C# |
---|
public void SetTypeId( ElementId typeId ) |
Visual Basic |
---|
Public Sub SetTypeId ( _ typeId As ElementId _ ) |
Visual C++ |
---|
public: void SetTypeId( ElementId^ typeId ) |
Parameters
- typeId
- Type: Autodesk.Revit.DB..::..ElementId
The ID of the type corresponding to this DirectShape element. May only be set once.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentException | typeId is not a valid Element identifier. |
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |