Sets the callback to be invoked in the beginning of failure processing.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since:  2011

Syntax

C#
public FailureHandlingOptions SetFailuresPreprocessor(
	IFailuresPreprocessor preprocessor
)
Visual Basic
Public Function SetFailuresPreprocessor ( _
	preprocessor As IFailuresPreprocessor _
) As FailureHandlingOptions
Visual C++
public:
FailureHandlingOptions^ SetFailuresPreprocessor(
	IFailuresPreprocessor^ preprocessor
)

Parameters

preprocessor
Type: Autodesk.Revit.DB..::..IFailuresPreprocessor
The callback to be invoked in the beginning of failure processing.

Return Value

This FailureHandlingOptions object.

Exceptions

ExceptionCondition
Autodesk.Revit.Exceptions..::..ArgumentNullException A non-optional argument was NULL

See Also