Identifies if the filter is enabled in this view.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2021
Syntax
C# |
---|
public bool GetIsFilterEnabled( ElementId filterElementId ) |
Visual Basic |
---|
Public Function GetIsFilterEnabled ( _ filterElementId As ElementId _ ) As Boolean |
Visual C++ |
---|
public: bool GetIsFilterEnabled( ElementId^ filterElementId ) |
Parameters
- filterElementId
- Type: Autodesk.Revit.DB..::..ElementId
The ElementId of the filter.
Return Value
True if the specified filter is enabled in this view, false otherwise.
Remarks
Several filters can be applied to a view in a certain order. This enable/disable flag
allows one to quickly turn on/off the action of a particular filter in this view (without
removing the filter from the set of applied filters and losing the corresponding overrides).
By default, all the filters applied to a view are enabled.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentException | Filter is not applied to the view. -or- ElementId is not associated with a FilterElement. |
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |
Autodesk.Revit.Exceptions..::..InvalidOperationException | View does not belong to a project document. -or- The view type does not support Visibility/Graphics Overriddes. |