Gets the id of the view referenced by a reference view (such as a reference section or reference callout).
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2015
Syntax
C# |
---|
public static ElementId GetReferencedViewId( Document document, ElementId referenceId ) |
Visual Basic |
---|
Public Shared Function GetReferencedViewId ( _ document As Document, _ referenceId As ElementId _ ) As ElementId |
Visual C++ |
---|
public: static ElementId^ GetReferencedViewId( Document^ document, ElementId^ referenceId ) |
Parameters
- document
- Type: Autodesk.Revit.DB..::..Document
The document containing the elements.
- referenceId
- Type: Autodesk.Revit.DB..::..ElementId
The reference view that will be changed to refer to a different View.
Return Value
The id of the referenced view.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentException | referenceId is not a valid reference view. |
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |