Checks whether the category can have graphic overrides in this view.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2014
Syntax
C# |
---|
public bool IsCategoryOverridable( ElementId categoryId ) |
Visual Basic |
---|
Public Function IsCategoryOverridable ( _ categoryId As ElementId _ ) As Boolean |
Visual C++ |
---|
public: bool IsCategoryOverridable( ElementId^ categoryId ) |
Parameters
- categoryId
- Type: Autodesk.Revit.DB..::..ElementId
ElementId of the category.
Return Value
True if category can be overridden, false otherwise.
Remarks
Categories can be allowed to be overridden in some view types and prohibited from being overridden in others.
E.g., categories cannot be overridden in ProjectBrowser
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |