Get the DuctSizes for this DuctShape.
Namespace: Autodesk.Revit.DB.MechanicalAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2012
Syntax
C# |
---|
public DuctSizes this[ DuctShape ductShape ] { get; } |
Visual Basic |
---|
Public ReadOnly Default Property Item ( _ ductShape As DuctShape _ ) As DuctSizes Get |
Visual C++ |
---|
public: property DuctSizes^ default[DuctShape ductShape] { DuctSizes^ get (DuctShape ductShape); } |
Parameters
- ductShape
- Type: Autodesk.Revit.DB.Mechanical..::..DuctShape
The duct shape.
Return Value
The DuctSizes for this DuctShape.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentException | There is no DuctSizes for this DuctShape. |
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |