Creates an arc through the given reference points.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2014
Syntax
C# |
---|
public static CurveElement CreateArcThroughPoints( Document document, ReferencePoint startPoint, ReferencePoint endPoint, ReferencePoint interiorPoint ) |
Visual Basic |
---|
Public Shared Function CreateArcThroughPoints ( _ document As Document, _ startPoint As ReferencePoint, _ endPoint As ReferencePoint, _ interiorPoint As ReferencePoint _ ) As CurveElement |
Visual C++ |
---|
public: static CurveElement^ CreateArcThroughPoints( Document^ document, ReferencePoint^ startPoint, ReferencePoint^ endPoint, ReferencePoint^ interiorPoint ) |
Parameters
- document
- Type: Autodesk.Revit.DB..::..Document
The Document.
- startPoint
- Type: Autodesk.Revit.DB..::..ReferencePoint
The start point of the arc.
- endPoint
- Type: Autodesk.Revit.DB..::..ReferencePoint
The end end of the arc.
- interiorPoint
- Type: Autodesk.Revit.DB..::..ReferencePoint
The interior point on the arc.
Return Value
The CurveElement to be created.
Remarks
The interiorPoint determines the orientation of the arc while startPoint and endPoint determine
the angle parameters at the ends.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |
Autodesk.Revit.Exceptions..::..InvalidOperationException | Can't create an arc from the given points |