Get the ElementId of the MassSurfaceData corresponding to the Reference.
Namespace: Autodesk.Revit.DB.AnalysisAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2012
Syntax
C# |
---|
public ElementId GetMassSurfaceDataIdForReference( Reference reference ) |
Visual Basic |
---|
Public Function GetMassSurfaceDataIdForReference ( _ reference As Reference _ ) As ElementId |
Visual C++ |
---|
public: ElementId^ GetMassSurfaceDataIdForReference( Reference^ reference ) |
Parameters
- reference
- Type: Autodesk.Revit.DB..::..Reference
A Reference to a face of this MassEnergyAnalyticalModel.
Return Value
ElementId of a MassSurfaceData.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentException | The Reference is not a Face of this MassEnergyAnalyticalModel. |
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |