The position of the run relative to the Up-direction path used to create the run.
Namespace: Autodesk.Revit.DB.ArchitectureAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2013
Syntax
C# |
---|
public StairsRunJustification LocationLineJustification { get; set; } |
Visual Basic |
---|
Public Property LocationLineJustification As StairsRunJustification Get Set |
Visual C++ |
---|
public: property StairsRunJustification LocationLineJustification { StairsRunJustification get (); void set (StairsRunJustification value); } |
Remarks
Only common runs(straight, spiral, winder) have location line justification.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: A value passed for an enumeration argument is not a member of that enumeration |
Autodesk.Revit.Exceptions..::..InvalidOperationException | The stairs run is sketched so the data being set is not applicable. |