The height above the level where the bottoms of auto-generated windows will be located.
Namespace: Autodesk.Revit.DB.AnalysisAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2012
Syntax
C# |
---|
public double SillHeight { get; set; } |
Visual Basic |
---|
Public Property SillHeight As Double Get Set |
Visual C++ |
---|
public: property double SillHeight { double get (); void set (double value); } |
Remarks
Will be accurate unless the target glazing percentage cannot be achieved using this height.
In that case, the sillHeight will be ignored and windows will be created below this height.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: The sill height is less than zero. |