Creates a new BeamSystem with specified profile curves.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since:
2014
Syntax
Visual Basic |
---|
Public Shared Function Create ( _
document As Document, _
profile As IList(Of Curve), _
level As Level, _
direction As XYZ, _
is3d As Boolean _
) As BeamSystem |
Parameters
- document
- Type: Autodesk.Revit.DB..::..Document
The document in which the new BeamSystem is created.
- profile
- Type: System.Collections.Generic..::..IList<(Of <(<'Curve>)>)>
The profile of the BeamSystem.
- level
- Type: Autodesk.Revit.DB..::..Level
The level on which the BeamSystem is to be created.
The work-plane of the BeamSystem will be the sketch plane associated with the Level.
If there is no current sketch plane associated with the level yet, we will create a default one.
- direction
- Type: Autodesk.Revit.DB..::..XYZ
The direction is the direction of the BeamSystem.
- is3d
- Type: System..::..Boolean
Whether the BeamSystem is 3D. If the BeamSystem is 3D, the sketchPlane must be a level, otherwise an exception will be thrown.
Return Value
If successful, a new BeamSystem object will be returned.
Exceptions
See Also