Checks if given template has the same panel schedule type with this template.
Namespace: Autodesk.Revit.DB.ElectricalAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2011
Syntax
C# |
---|
public bool HasSameType( PanelScheduleTemplate otherTemplate ) |
Visual Basic |
---|
Public Function HasSameType ( _ otherTemplate As PanelScheduleTemplate _ ) As Boolean |
Visual C++ |
---|
public: bool HasSameType( PanelScheduleTemplate^ otherTemplate ) |
Parameters
- otherTemplate
- Type: Autodesk.Revit.DB.Electrical..::..PanelScheduleTemplate
The given template to check.
Return Value
True if the given template has the same panel schedule type with this template, false otherwise.
Remarks
The panel schedule type is the enum type of PanelScheduleType class (Branch, switchboard, data etc.)
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |