Creates an object which wraps the arguments of NewFamilyInstance() for batch creation.
Namespace: Autodesk.Revit.CreationAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Syntax
C# |
---|
public FamilyInstanceCreationData NewFamilyInstanceCreationData( FamilySymbol symbol, IList<XYZ> adaptivePoints ) |
Visual Basic |
---|
Public Function NewFamilyInstanceCreationData ( _ symbol As FamilySymbol, _ adaptivePoints As IList(Of XYZ) _ ) As FamilyInstanceCreationData |
Visual C++ |
---|
public: FamilyInstanceCreationData^ NewFamilyInstanceCreationData( FamilySymbol^ symbol, IList<XYZ^>^ adaptivePoints ) |
Parameters
- symbol
- Type: Autodesk.Revit.DB..::..FamilySymbol
A FamilySymbol object that represents the type of the instance that is to be inserted.
- adaptivePoints
- Type: System.Collections.Generic..::..IList<(Of <(<'XYZ>)>)>
The adaptive point location where the adaptive instance is to be placed.