Returns a list of names of dwg/dxf export settings.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2013
Syntax
C# |
---|
public static IList<string> ListNames( Document aDoc ) |
Visual Basic |
---|
Public Shared Function ListNames ( _ aDoc As Document _ ) As IList(Of String) |
Visual C++ |
---|
public: static IList<String^>^ ListNames( Document^ aDoc ) |
Parameters
- aDoc
- Type: Autodesk.Revit.DB..::..Document
A Revit document to retrieve names from.
Return Value
An array of strings representing names of predefined setups.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |