Retrieves other Element Ids against which the Analytical Model has been adjusted.
Namespace: Autodesk.Revit.DB.StructureAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2011
Syntax
C# |
---|
public ICollection<ElementId> GetManualAdjustmentMatchedElements() |
Visual Basic |
---|
Public Function GetManualAdjustmentMatchedElements As ICollection(Of ElementId) |
Visual C++ |
---|
public: ICollection<ElementId^>^ GetManualAdjustmentMatchedElements() |
Return Value
Set of Element Ids, representing those Elements against which the Analytical Model has been adjusted. The set may be empty if Analytical Model is not participating in locked Manual Analytical Adjustment.
Remarks
This is only meaningful for locked Manual Analytical Adjustment. When operating
unlocked, the Analytical Model is offset by a certain amount, not against a given Element.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..InvalidOperationException | This AnalyticalModel does not support Manual Analytical Adjustment. |