Convert all temporary hidden elements or categories to permanently hidden in view.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2013
Syntax
C# |
---|
public void ConvertTemporaryHideIsolateToPermanent() |
Visual Basic |
---|
Public Sub ConvertTemporaryHideIsolateToPermanent |
Visual C++ |
---|
public: void ConvertTemporaryHideIsolateToPermanent() |
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..InvalidOperationException | View does not belong to a project document. |
Autodesk.Revit.Exceptions..::..ModificationForbiddenException | This View is an internal element, such as a component of a loaded family or a group type. -or- The document containing this View is in Group Edit Mode, Sketch Edit Mode, or Paste Mode, and the element is not a member of the group, sketch, or clipboard. -or- This View is a member of a group or sketch, and the document is not currently editing the group or sketch. |