Exports the document in 3D-Studio Max (FBX) format.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Syntax
Visual Basic |
---|
Public Function Export ( _
folder As String, _
name As String, _
views As ViewSet, _
options As FBXExportOptions _
) As Boolean |
Parameters
- folder
- Type: System..::..String
Output folder, into which file(s) will be exported. The folder must exist.
- name
- Type: System..::..String
Either the name of a single file or a prefix for a set of files.
If nullNothingnullptra null reference (Nothing in Visual Basic) or empty, automatic naming will be used.
- views
- Type: Autodesk.Revit.DB..::..ViewSet
Selection of views to be exported.Only 3D views are allowed.
- options
- Type: Autodesk.Revit.DB..::..FBXExportOptions
Options applicable to the FBX format.
Return Value
Function returns true only if all specified views are exported successfully.
The function returns False if exporting of any view fails, even if some views might have been exported successfully.
Remarks
Exceptions
See Also