A copy of the ExportPatternInfo for the pattern's ExportPatternKey.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2014
Syntax
C# |
---|
public ExportPatternInfo this[ ExportPatternKey patternKey ] { get; set; } |
Visual Basic |
---|
Public Default Property Item ( _ patternKey As ExportPatternKey _ ) As ExportPatternInfo Get Set |
Visual C++ |
---|
public: virtual property ExportPatternInfo^ default[ExportPatternKey^ patternKey] { ExportPatternInfo^ get (ExportPatternKey^ patternKey) sealed; void set (ExportPatternKey^ patternKey, ExportPatternInfo^ value) sealed; } |
Parameters
- patternKey
- Type: Autodesk.Revit.DB..::..ExportPatternKey
Return Value
A copy of the ExportPatternInfo.
Remarks
When getting this property, it returns a copy of the ExportPatternInfo from the table. In order to
make changes to the ExportPatternInfo and use those settings during export, set the modified
ExportPatternInfo back into the table using the same key.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentException | When getting this property: An entry with the given key is not present in the table. |