Transforms this curve loop and all of its component curves by the supplied transformation.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2016
Syntax
C# |
---|
public void Transform( Transform transform ) |
Visual Basic |
---|
Public Sub Transform ( _ transform As Transform _ ) |
Visual C++ |
---|
public: void Transform( Transform^ transform ) |
Parameters
- transform
- Type: Autodesk.Revit.DB..::..Transform
The transformation.
Remarks
The modified CurveLoop is guaranteed to be valid with all consituent curves contiguous (assuming
that the curves were contiguous in the input curve loop).
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | transform is not conformal. -or- transform has a scale that is negative or zero. |