Gets the associate family parameter id of the specified connector parameter id.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since:  2017

Syntax

C#
public ElementId GetAssociateFamilyParameterId(
	ElementId connectorParameterId
)
Visual Basic
Public Function GetAssociateFamilyParameterId ( _
	connectorParameterId As ElementId _
) As ElementId
Visual C++
public:
ElementId^ GetAssociateFamilyParameterId(
	ElementId^ connectorParameterId
)

Parameters

connectorParameterId
Type: Autodesk.Revit.DB..::..ElementId
connectorParameterId is defined in the family connector element.

Return Value

Returns valid ElementId if the connectorParameterId associates to one family parameter; otherwise returns invalid ElementId.

Exceptions

ExceptionCondition
Autodesk.Revit.Exceptions..::..ArgumentNullException A non-optional argument was NULL

See Also