Gets the user-visible name for a UnitType.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2011
Syntax
C# |
---|
[ObsoleteAttribute("This method is deprecated in Revit 2021 and may be removed in a future version of Revit. Please use the `GetLabelForSpec(ForgeTypeId)` method instead.")] public static string GetLabelFor( UnitType unitType ) |
Visual Basic |
---|
<ObsoleteAttribute("This method is deprecated in Revit 2021 and may be removed in a future version of Revit. Please use the `GetLabelForSpec(ForgeTypeId)` method instead.")> _ Public Shared Function GetLabelFor ( _ unitType As UnitType _ ) As String |
Visual C++ |
---|
[ObsoleteAttribute(L"This method is deprecated in Revit 2021 and may be removed in a future version of Revit. Please use the `GetLabelForSpec(ForgeTypeId)` method instead.")] public: static String^ GetLabelFor( UnitType unitType ) |
Parameters
- unitType
- Type: Autodesk.Revit.DB..::..UnitType
The UnitType to get the user-visible name.
Remarks
The name is obtained in the current Revit language.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentException | Cannot find UnitTypeInfo for the UnitType. |
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration |