Retrieves or changes the material of the category.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Syntax
C# |
---|
public Material Material { get; set; } |
Visual Basic |
---|
Public Property Material As Material Get Set |
Visual C++ |
---|
public: property Material^ Material { Material^ get (); void set (Material^ value); } |
Field Value
nullNothingnullptra null reference (Nothing in Visual Basic) if this category does not have a material.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..InvalidOperationException | When setting this property: material cannot be set for annotation categories. |